<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":2,"applicationTime":317,"agent":""}</script>
<script type="text/javascript">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</script>
<!-- GUCE -->
<meta content='false' name='oath:guce:product-eu'>
<meta content='guce.rivals.com' name='oath:guce:consent-host'>
<script src="https://s.yimg.com/oa/guce.js" async="async"></script>
<script>
  var googleAnalyticsId = "UA-81917412-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<title>BeaversEdge.com  -  Fowler raves about Oregon State visit</title>
<meta content='BeaversEdge.com  -  Fowler raves about Oregon State visit' property='og:title'>
<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-2eada6c4ef76b32c1d573f4c7ad6fd2ed16b2c21706319015a98c50ca76b4e2e.css" />

<script src="https://cdn.rivals.com/production/assets/application-bd8e0400049933d7d82b6800a27663d3f82104735ca93ffa4c021e578eb2a73b.js"></script>
<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="NSrHh1J5GXX3zQU2M/05wU41qXRlX0TPCAaqMdfcOURBmaDLbwEufLcOR/g3OUozbE3rNrlq8VpUUusF8//t7A==" />
<script type="application/javascript">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</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://oregonstate.rivals.com/news/fowler-raves-about-oregon-state-visit' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_thumbnail/ndulp6zglbavaipvavck' property='og:image'>
<meta content='Bellevue (Wash.) inside linebacker Drew Fowler earned an offer from the Oregon State Beavers on April 10, and it ...' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2018-04-25 11:34:35 -0500' property='article:published_time'>
<meta content='2018-04-25 11:34:36 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<meta content='Drew Fowler' property='article:tag'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "oregonstate.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='oregonstate contents-show_updated_layout' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  @media screen and (max-width: 1023px) {
    .oregonstate #programming > h1 {
      background-color: #000000 !important; } }
  .oregonstate > header .notification-link .count-container {
    background-color: #000000 !important; }
  .oregonstate > header .wrapper-container {
    background-color: #000000 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .oregonstate > header .wrapper-container {
        border-bottom: 5px solid #ff8c1f !important; } }
  .oregonstate > header .invalid-email-banner {
    background-color: #000000;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .oregonstate > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .oregonstate > header .invalid-email-banner a:hover {
      color: #ff8c1f; }
  @media screen and (max-width: 767px) {
    .oregonstate > header .mobile-header {
      background-color: #ff8c1f !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .oregonstate > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .oregonstate > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .oregonstate > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .oregonstate > header .nav-row > ul,
    .oregonstate > header .third-nav {
      background-color: white !important; }
    .oregonstate > header .dropdown-toggle > i.fa {
      color: #000000 !important; } }
  .oregonstate > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #000000; }
  
  .site-primary-font-color {
    color: #000000; }
  
  .site-primary-background-color {
    background-color: #000000; }
  
  .site-secondary-font-color {
    color: #ff8c1f; }
  
  .site-secondary-background-color {
    background-color: #ff8c1f; }
  
  :root {
    --outbrain-primary-color: #000000;
    --outbrain-secondary-color: #ff8c1f; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-controller='NavController as ctrl' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="//Rivals.rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="Oregon State" class="school-header" href="//oregonstate.rivals.com"><img src="https://res-4.cloudinary.com/rivals/image/upload/qb3tjv5av7mcnjvukacf" alt="Qb3tjv5av7mcnjvukacf" />
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span>Join the Rivals community!</span>
          <a class='btn' ng-href='{{ ctrl.subscribePath }}'>Subscribe</a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && (ctrl.isDesktop || ctrl.isTablet)'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="//oregonstate.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;oregonstate&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="//oregonstate.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;oregonstate&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022733135,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Fowler raves about Oregon State visit"
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='Rivals_Singer' name='twitter:site'>
<meta content='Fowler raves about Oregon State visit' name='twitter:title'>
<meta content='Bellevue (Wash.) inside linebacker Drew Fowler earned an offer from the Oregon State Beavers on April 10, and it ...' name='twitter:description'>
<meta content='https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/ndulp6zglbavaipvavck' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init([{"id":1910616,"title":"Oregon State Spring Football Headquarters","slug":"oregon-state-spring-football-headquarters-1","kind":"free","site_id":112,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-20T16:44:12.468-05:00","summary":"BeaversEdge.com will be live in Corvallis for every spring practice. Check out our spring ball content as well as the...","deleted":false,"author_name":"BeaversEdge.com","author_title":"Staff","permalink":"https://oregonstate.rivals.com/news/oregon-state-spring-football-headquarters-1","site_name":"BeaversEdge.com","type":"Content","programming":[112],"associated_links":[{"id":535,"url":"https://oregonstate.forums.rivals.com/forums/the-dam-board.8/","display_text":"The Dam Board","content_id":null,"created_at":"2017-02-15T15:24:56.986-06:00","updated_at":"2017-12-09T10:51:51.050-06:00","setting_id":132,"ordinality":1},{"id":536,"url":"https://oregonstate.rivals.com/news/beaversedge-com-testimonial-page","display_text":"Why subscribe to BeaversEdge?","content_id":null,"created_at":"2017-02-15T15:24:56.992-06:00","updated_at":"2017-09-27T09:43:48.538-05:00","setting_id":132,"ordinality":2}]},{"id":1917271,"title":"Oregon State hosting three-star guard for official visit","slug":"oregon-state-hosting-three-star-guard-for-official-visit","kind":"free","site_id":112,"sport":"basketball","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-24T18:19:59.620-05:00","summary":"Victorville (Calif.) Victor Valley shooting guard Jordan Campbell will officially visit Oregon State on Wednesday.","deleted":false,"author_name":"Mike Singer","author_title":"BeaversEdge.com","permalink":"https://oregonstate.rivals.com/news/oregon-state-hosting-three-star-guard-for-official-visit","site_name":"BeaversEdge.com","type":"Content","programming":[],"associated_links":[{"id":535,"url":"https://oregonstate.forums.rivals.com/forums/the-dam-board.8/","display_text":"The Dam Board","content_id":null,"created_at":"2017-02-15T15:24:56.986-06:00","updated_at":"2017-12-09T10:51:51.050-06:00","setting_id":132,"ordinality":1},{"id":536,"url":"https://oregonstate.rivals.com/news/beaversedge-com-testimonial-page","display_text":"Why subscribe to BeaversEdge?","content_id":null,"created_at":"2017-02-15T15:24:56.992-06:00","updated_at":"2017-09-27T09:43:48.538-05:00","setting_id":132,"ordinality":2}]},{"id":1917100,"title":"Nimmo Jr. enjoys quick stop at Oregon State, talks offer","slug":"nimmo-jr-enjoys-quick-stop-at-oregon-state-talks-offer","kind":"premium","site_id":112,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-24T10:26:00.214-05:00","summary":"Santa Ana (Calif.) Mater Dei safety William Nimmo Jr. took a pair of visits last Saturday, visiting Oregon State early..","deleted":false,"author_name":"Mike Singer","author_title":"BeaversEdge.com","permalink":"https://oregonstate.rivals.com/news/nimmo-jr-enjoys-quick-stop-at-oregon-state-talks-offer","site_name":"BeaversEdge.com","type":"Content","programming":[],"associated_links":[{"id":535,"url":"https://oregonstate.forums.rivals.com/forums/the-dam-board.8/","display_text":"The Dam Board","content_id":null,"created_at":"2017-02-15T15:24:56.986-06:00","updated_at":"2017-12-09T10:51:51.050-06:00","setting_id":132,"ordinality":1},{"id":536,"url":"https://oregonstate.rivals.com/news/beaversedge-com-testimonial-page","display_text":"Why subscribe to BeaversEdge?","content_id":null,"created_at":"2017-02-15T15:24:56.992-06:00","updated_at":"2017-09-27T09:43:48.538-05:00","setting_id":132,"ordinality":2}]},{"id":1917069,"title":"Franke was &#x0027;thrilled&#x0027; about his Oregon State offer","slug":"franke-was-thrilled-about-his-oregon-state-offer","kind":"free","site_id":112,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-24T08:59:54.946-05:00","summary":"Oregon State became the first scholarship offer for Westlake Village (Calif.) Oaks Christian defensive end/outside...","deleted":false,"author_name":"Mike Singer","author_title":"BeaversEdge.com","permalink":"https://oregonstate.rivals.com/news/franke-was-thrilled-about-his-oregon-state-offer","site_name":"BeaversEdge.com","type":"Content","programming":[],"associated_links":[{"id":535,"url":"https://oregonstate.forums.rivals.com/forums/the-dam-board.8/","display_text":"The Dam Board","content_id":null,"created_at":"2017-02-15T15:24:56.986-06:00","updated_at":"2017-12-09T10:51:51.050-06:00","setting_id":132,"ordinality":1},{"id":536,"url":"https://oregonstate.rivals.com/news/beaversedge-com-testimonial-page","display_text":"Why subscribe to BeaversEdge?","content_id":null,"created_at":"2017-02-15T15:24:56.992-06:00","updated_at":"2017-09-27T09:43:48.538-05:00","setting_id":132,"ordinality":2}]},{"id":1916950,"title":"NUGGETS: Blount, Colletto, Luton continue QB competition","slug":"nuggets-blount-luton-lead-quarterback-competition","kind":"free","site_id":112,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-23T17:18:09.088-05:00","summary":"Today&#x0027;s practice was open to the media, and BeaversEdge.com has the very detailed report on how each position group...","deleted":false,"author_name":"Keenan Puncocher","author_title":"Staff","permalink":"https://oregonstate.rivals.com/news/nuggets-blount-luton-lead-quarterback-competition","site_name":"BeaversEdge.com","type":"Content","programming":[],"associated_links":[{"id":535,"url":"https://oregonstate.forums.rivals.com/forums/the-dam-board.8/","display_text":"The Dam Board","content_id":null,"created_at":"2017-02-15T15:24:56.986-06:00","updated_at":"2017-12-09T10:51:51.050-06:00","setting_id":132,"ordinality":1},{"id":536,"url":"https://oregonstate.rivals.com/news/beaversedge-com-testimonial-page","display_text":"Why subscribe to BeaversEdge?","content_id":null,"created_at":"2017-02-15T15:24:56.992-06:00","updated_at":"2017-09-27T09:43:48.538-05:00","setting_id":132,"ordinality":2}]},{"id":1916933,"title":"Notebook: Oregon State Spring Practice - Day 12","slug":"notebook-oregon-state-spring-practice-day-12","kind":"premium","site_id":112,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-23T16:25:27.106-05:00","summary":"For the first time since their senior day loss to Arizona State in November, the Oregon State football team returned to","deleted":false,"author_name":"Brenden Slaughter","author_title":"Senior Writer","permalink":"https://oregonstate.rivals.com/news/notebook-oregon-state-spring-practice-day-12","site_name":"BeaversEdge.com","type":"Content","programming":[],"associated_links":[{"id":535,"url":"https://oregonstate.forums.rivals.com/forums/the-dam-board.8/","display_text":"The Dam Board","content_id":null,"created_at":"2017-02-15T15:24:56.986-06:00","updated_at":"2017-12-09T10:51:51.050-06:00","setting_id":132,"ordinality":1},{"id":536,"url":"https://oregonstate.rivals.com/news/beaversedge-com-testimonial-page","display_text":"Why subscribe to BeaversEdge?","content_id":null,"created_at":"2017-02-15T15:24:56.992-06:00","updated_at":"2017-09-27T09:43:48.538-05:00","setting_id":132,"ordinality":2}]},{"id":1916910,"title":"WATCH: Oregon State Spring Practice Interviews - Day 12","slug":"watch-oregon-state-spring-practice-interviews-day-12","kind":"free","site_id":112,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-23T15:16:18.741-05:00","summary":"Hear from Oregon State offensive coordinator Brian Lindgren, quarterback Jake Luton, and...","deleted":false,"author_name":"BeaversEdge.com","author_title":"Staff","permalink":"https://oregonstate.rivals.com/news/watch-oregon-state-spring-practice-interviews-day-12","site_name":"BeaversEdge.com","type":"Content","programming":[],"associated_links":[{"id":535,"url":"https://oregonstate.forums.rivals.com/forums/the-dam-board.8/","display_text":"The Dam Board","content_id":null,"created_at":"2017-02-15T15:24:56.986-06:00","updated_at":"2017-12-09T10:51:51.050-06:00","setting_id":132,"ordinality":1},{"id":536,"url":"https://oregonstate.rivals.com/news/beaversedge-com-testimonial-page","display_text":"Why subscribe to BeaversEdge?","content_id":null,"created_at":"2017-02-15T15:24:56.992-06:00","updated_at":"2017-09-27T09:43:48.538-05:00","setting_id":132,"ordinality":2}]},{"id":1915993,"title":"Craig Evans relishes new opportunity","slug":"craig-evans-relishes-new-opportunity","kind":"free","site_id":112,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-23T08:04:11.265-05:00","summary":"What is next for Craig Evans? He spoke with BeaversEdge.com about his decision and how he came to it.","deleted":false,"author_name":"Mike Singer","author_title":"BeaversEdge.com","permalink":"https://oregonstate.rivals.com/news/craig-evans-relishes-new-opportunity","site_name":"BeaversEdge.com","type":"Content","programming":[],"associated_links":[{"id":535,"url":"https://oregonstate.forums.rivals.com/forums/the-dam-board.8/","display_text":"The Dam Board","content_id":null,"created_at":"2017-02-15T15:24:56.986-06:00","updated_at":"2017-12-09T10:51:51.050-06:00","setting_id":132,"ordinality":1},{"id":536,"url":"https://oregonstate.rivals.com/news/beaversedge-com-testimonial-page","display_text":"Why subscribe to BeaversEdge?","content_id":null,"created_at":"2017-02-15T15:24:56.992-06:00","updated_at":"2017-09-27T09:43:48.538-05:00","setting_id":132,"ordinality":2}]},{"id":1916608,"title":"Oregon State rolls out the red carpet for Thorpe","slug":"oregon-state-rolls-out-the-red-carpet-for-thorpe","kind":"premium","site_id":112,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-22T17:33:07.970-05:00","summary":"On Friday, Oregon State hosted Walnut Creek (Calif.) Los Lomas wide receiver/tight end Blake Thorpe for an unofficial...","deleted":false,"author_name":"Mike Singer","author_title":"BeaversEdge.com","permalink":"https://oregonstate.rivals.com/news/oregon-state-rolls-out-the-red-carpet-for-thorpe","site_name":"BeaversEdge.com","type":"Content","programming":[],"associated_links":[{"id":535,"url":"https://oregonstate.forums.rivals.com/forums/the-dam-board.8/","display_text":"The Dam Board","content_id":null,"created_at":"2017-02-15T15:24:56.986-06:00","updated_at":"2017-12-09T10:51:51.050-06:00","setting_id":132,"ordinality":1},{"id":536,"url":"https://oregonstate.rivals.com/news/beaversedge-com-testimonial-page","display_text":"Why subscribe to BeaversEdge?","content_id":null,"created_at":"2017-02-15T15:24:56.992-06:00","updated_at":"2017-09-27T09:43:48.538-05:00","setting_id":132,"ordinality":2}]},{"id":1916556,"title":"WATCH: Oregon State Practice Highlights","slug":"watch-oregon-state-practice-highlights-1","kind":"free","site_id":112,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-22T13:50:58.970-05:00","summary":"Check out highlights from Oregon State&#x0027;s practice on April 20, 2018 from BeaversEdge.com.","deleted":false,"author_name":"BeaversEdge.com","author_title":"Staff","permalink":"https://oregonstate.rivals.com/news/watch-oregon-state-practice-highlights-1","site_name":"BeaversEdge.com","type":"Content","programming":[],"associated_links":[{"id":535,"url":"https://oregonstate.forums.rivals.com/forums/the-dam-board.8/","display_text":"The Dam Board","content_id":null,"created_at":"2017-02-15T15:24:56.986-06:00","updated_at":"2017-12-09T10:51:51.050-06:00","setting_id":132,"ordinality":1},{"id":536,"url":"https://oregonstate.rivals.com/news/beaversedge-com-testimonial-page","display_text":"Why subscribe to BeaversEdge?","content_id":null,"created_at":"2017-02-15T15:24:56.992-06:00","updated_at":"2017-09-27T09:43:48.538-05:00","setting_id":132,"ordinality":2}]},{"id":1916404,"title":"Beavers defeat Ducks 12-5; sweep series","slug":"beavers-defeat-ducks-12-5-sweep-series","kind":"free","site_id":112,"sport":"baseball","news_type":"team","content_type":"Content::Article","live_at":"2018-04-21T22:29:50.664-05:00","summary":"OSU&#x0027;s bats explode in the finale as the Beavers sweep Oregon for the second straight season. ","deleted":false,"author_name":"BeaversEdge.com","author_title":"Staff","permalink":"https://oregonstate.rivals.com/news/beavers-defeat-ducks-12-5-sweep-series","site_name":"BeaversEdge.com","type":"Content","programming":[],"associated_links":[{"id":5085,"url":"https://oregonstate.rivals.com/news/two-commits-three-big-targets-visiting-oregon-state-on-saturday","display_text":"OSU football recruiting scoop","content_id":1916404,"created_at":"2018-04-21T22:29:51.392-05:00","updated_at":"2018-04-21T22:29:51.392-05:00","setting_id":null,"ordinality":1},{"id":5086,"url":"https://oregonstate.rivals.com/news/beavers-clinch-civil-war-series","display_text":"Beavers clinch Civil War series","content_id":1916404,"created_at":"2018-04-21T22:29:51.395-05:00","updated_at":"2018-04-21T22:29:51.395-05:00","setting_id":null,"ordinality":2}]},{"id":1916243,"title":"Two commits, three big targets visiting Oregon State on Saturday","slug":"two-commits-three-big-targets-visiting-oregon-state-on-saturday","kind":"premium","site_id":112,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-21T10:42:04.980-05:00","summary":"Oregon State is hosting a big crop of visitors on Saturday, with five prospects being the most notable. ","deleted":false,"author_name":"Mike Singer","author_title":"BeaversEdge.com","permalink":"https://oregonstate.rivals.com/news/two-commits-three-big-targets-visiting-oregon-state-on-saturday","site_name":"BeaversEdge.com","type":"Content","programming":[],"associated_links":[{"id":535,"url":"https://oregonstate.forums.rivals.com/forums/the-dam-board.8/","display_text":"The Dam Board","content_id":null,"created_at":"2017-02-15T15:24:56.986-06:00","updated_at":"2017-12-09T10:51:51.050-06:00","setting_id":132,"ordinality":1},{"id":536,"url":"https://oregonstate.rivals.com/news/beaversedge-com-testimonial-page","display_text":"Why subscribe to BeaversEdge?","content_id":null,"created_at":"2017-02-15T15:24:56.992-06:00","updated_at":"2017-09-27T09:43:48.538-05:00","setting_id":132,"ordinality":2}]},{"id":1916154,"title":"Beavers clinch Civil War series ","slug":"beavers-clinch-civil-war-series","kind":"free","site_id":112,"sport":"baseball","news_type":"team","content_type":"Content::Article","live_at":"2018-04-20T21:46:06.859-05:00","summary":"Behind strong pitching from Bryce Fehmel and a solo home run from Tyler Malone, the Beavers clinch the series vs Oregon.","deleted":false,"author_name":"BeaversEdge.com","author_title":"Staff","permalink":"https://oregonstate.rivals.com/news/beavers-clinch-civil-war-series","site_name":"BeaversEdge.com","type":"Content","programming":[],"associated_links":[{"id":5057,"url":"https://oregonstate.rivals.com/news/nuggets-in-depth-breakdown-of-oregon-state-s-10th-practice","display_text":"OSU Spring FB Day 10 Nuggets","content_id":1916154,"created_at":"2018-04-20T21:46:07.582-05:00","updated_at":"2018-04-20T21:46:07.582-05:00","setting_id":null,"ordinality":1},{"id":5058,"url":"https://oregonstate.rivals.com/news/notebook-oregon-state-spring-practice-day-10","display_text":"OSU Spring FB Day 10 Notebook","content_id":1916154,"created_at":"2018-04-20T21:46:07.585-05:00","updated_at":"2018-04-20T21:46:07.585-05:00","setting_id":null,"ordinality":2}]},{"id":1916105,"title":"NUGGETS: In-depth breakdown of Oregon State&#x0027;s 10th practice","slug":"nuggets-in-depth-breakdown-of-oregon-state-s-10th-practice","kind":"free","site_id":112,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-20T16:29:28.404-05:00","summary":"Today&#x0027;s practice was open to the media, and BeaversEdge.com has the very detailed report on how each position group","deleted":false,"author_name":"Keenan Puncocher","author_title":"Staff","permalink":"https://oregonstate.rivals.com/news/nuggets-in-depth-breakdown-of-oregon-state-s-10th-practice","site_name":"BeaversEdge.com","type":"Content","programming":[],"associated_links":[{"id":535,"url":"https://oregonstate.forums.rivals.com/forums/the-dam-board.8/","display_text":"The Dam Board","content_id":null,"created_at":"2017-02-15T15:24:56.986-06:00","updated_at":"2017-12-09T10:51:51.050-06:00","setting_id":132,"ordinality":1},{"id":536,"url":"https://oregonstate.rivals.com/news/beaversedge-com-testimonial-page","display_text":"Why subscribe to BeaversEdge?","content_id":null,"created_at":"2017-02-15T15:24:56.992-06:00","updated_at":"2017-09-27T09:43:48.538-05:00","setting_id":132,"ordinality":2}]},{"id":1916103,"title":"Notebook: Oregon State Spring Practice - Day 10","slug":"notebook-oregon-state-spring-practice-day-10","kind":"premium","site_id":112,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-20T16:14:24.503-05:00","summary":"Heading into the 2018 campaign, head coach Jonathan Smith and defensive coordinator Tim Tibesar knew that they were..","deleted":false,"author_name":"Brenden Slaughter","author_title":"Senior Writer","permalink":"https://oregonstate.rivals.com/news/notebook-oregon-state-spring-practice-day-10","site_name":"BeaversEdge.com","type":"Content","programming":[],"associated_links":[{"id":535,"url":"https://oregonstate.forums.rivals.com/forums/the-dam-board.8/","display_text":"The Dam Board","content_id":null,"created_at":"2017-02-15T15:24:56.986-06:00","updated_at":"2017-12-09T10:51:51.050-06:00","setting_id":132,"ordinality":1},{"id":536,"url":"https://oregonstate.rivals.com/news/beaversedge-com-testimonial-page","display_text":"Why subscribe to BeaversEdge?","content_id":null,"created_at":"2017-02-15T15:24:56.992-06:00","updated_at":"2017-09-27T09:43:48.538-05:00","setting_id":132,"ordinality":2}]},{"id":1916080,"title":"WATCH: Oregon State Spring Practice Interviews - Day 10","slug":"watch-oregon-state-spring-practice-interviews-day-10","kind":"free","site_id":112,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-20T14:55:26.653-05:00","summary":"Hear from Oregon State head coach Jonathan Smith, quarterback Jake Luton, and ...","deleted":false,"author_name":"BeaversEdge.com","author_title":"Staff","permalink":"https://oregonstate.rivals.com/news/watch-oregon-state-spring-practice-interviews-day-10","site_name":"BeaversEdge.com","type":"Content","programming":[],"associated_links":[{"id":535,"url":"https://oregonstate.forums.rivals.com/forums/the-dam-board.8/","display_text":"The Dam Board","content_id":null,"created_at":"2017-02-15T15:24:56.986-06:00","updated_at":"2017-12-09T10:51:51.050-06:00","setting_id":132,"ordinality":1},{"id":536,"url":"https://oregonstate.rivals.com/news/beaversedge-com-testimonial-page","display_text":"Why subscribe to BeaversEdge?","content_id":null,"created_at":"2017-02-15T15:24:56.992-06:00","updated_at":"2017-09-27T09:43:48.538-05:00","setting_id":132,"ordinality":2}]},{"id":1915848,"title":"Oregon State announces Quitoriano&#x0027;s signing with the Beavers","slug":"oregon-state-announces-quitoriano-signs-with-the-beavers","kind":"free","site_id":112,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-19T18:08:01.708-05:00","summary":"CORVALLIS, Ore. – Oregon State football head coach Jonathan Smith announced Thursday the addition of tight end Teagan...","deleted":false,"author_name":"BeaversEdge.com","author_title":"Staff","permalink":"https://oregonstate.rivals.com/news/oregon-state-announces-quitoriano-signs-with-the-beavers","site_name":"BeaversEdge.com","type":"Content","programming":[],"associated_links":[{"id":535,"url":"https://oregonstate.forums.rivals.com/forums/the-dam-board.8/","display_text":"The Dam Board","content_id":null,"created_at":"2017-02-15T15:24:56.986-06:00","updated_at":"2017-12-09T10:51:51.050-06:00","setting_id":132,"ordinality":1},{"id":536,"url":"https://oregonstate.rivals.com/news/beaversedge-com-testimonial-page","display_text":"Why subscribe to BeaversEdge?","content_id":null,"created_at":"2017-02-15T15:24:56.992-06:00","updated_at":"2017-09-27T09:43:48.538-05:00","setting_id":132,"ordinality":2}]},{"id":1915661,"title":"PODCAST: Discussing the \"Family Feel\" at Oregon State&#x0027;s Practices","slug":"podcast-discussing-the-family-feel-at-oregon-state-s-practices","kind":"free","site_id":112,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-19T10:32:38.114-05:00","summary":"BeaversEdge.com&#x0027;s Mike Singer and Brenden Slaughter discuss Oregon State spring football in this can&#x0027;t miss episode.","deleted":false,"author_name":"BeaversEdge.com","author_title":"Staff","permalink":"https://oregonstate.rivals.com/news/podcast-discussing-the-family-feel-at-oregon-state-s-practices","site_name":"BeaversEdge.com","type":"Content","programming":[],"associated_links":[{"id":535,"url":"https://oregonstate.forums.rivals.com/forums/the-dam-board.8/","display_text":"The Dam Board","content_id":null,"created_at":"2017-02-15T15:24:56.986-06:00","updated_at":"2017-12-09T10:51:51.050-06:00","setting_id":132,"ordinality":1},{"id":536,"url":"https://oregonstate.rivals.com/news/beaversedge-com-testimonial-page","display_text":"Why subscribe to BeaversEdge?","content_id":null,"created_at":"2017-02-15T15:24:56.992-06:00","updated_at":"2017-09-27T09:43:48.538-05:00","setting_id":132,"ordinality":2}]},{"id":1915615,"title":"Visitor List: Talented pass catcher visiting Oregon State this week","slug":"visitor-list-talented-pass-catchers-visiting-oregon-state-this-week","kind":"premium","site_id":112,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-19T09:47:18.635-05:00","summary":"Under head coach Jonathan Smith, the Beavers seem to be more aggressive with having top in-state prospects visit ...","deleted":false,"author_name":"Mike Singer","author_title":"BeaversEdge.com","permalink":"https://oregonstate.rivals.com/news/visitor-list-talented-pass-catchers-visiting-oregon-state-this-week","site_name":"BeaversEdge.com","type":"Content","programming":[],"associated_links":[{"id":535,"url":"https://oregonstate.forums.rivals.com/forums/the-dam-board.8/","display_text":"The Dam Board","content_id":null,"created_at":"2017-02-15T15:24:56.986-06:00","updated_at":"2017-12-09T10:51:51.050-06:00","setting_id":132,"ordinality":1},{"id":536,"url":"https://oregonstate.rivals.com/news/beaversedge-com-testimonial-page","display_text":"Why subscribe to BeaversEdge?","content_id":null,"created_at":"2017-02-15T15:24:56.992-06:00","updated_at":"2017-09-27T09:43:48.538-05:00","setting_id":132,"ordinality":2}]},{"id":1915420,"title":"Notebook: Oregon State Spring Practice - Day 9","slug":"notebook-oregon-state-spring-practice-day-9","kind":"premium","site_id":112,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-18T16:13:58.455-05:00","summary":"When OSU’s running backs coach Michael Pitre came to OSU, the Beavers still technically had Ryan Nall and had a great...","deleted":false,"author_name":"Brenden Slaughter","author_title":"Senior Writer","permalink":"https://oregonstate.rivals.com/news/notebook-oregon-state-spring-practice-day-9","site_name":"BeaversEdge.com","type":"Content","programming":[],"associated_links":[{"id":535,"url":"https://oregonstate.forums.rivals.com/forums/the-dam-board.8/","display_text":"The Dam Board","content_id":null,"created_at":"2017-02-15T15:24:56.986-06:00","updated_at":"2017-12-09T10:51:51.050-06:00","setting_id":132,"ordinality":1},{"id":536,"url":"https://oregonstate.rivals.com/news/beaversedge-com-testimonial-page","display_text":"Why subscribe to BeaversEdge?","content_id":null,"created_at":"2017-02-15T15:24:56.992-06:00","updated_at":"2017-09-27T09:43:48.538-05:00","setting_id":132,"ordinality":2}]},{"id":1915358,"title":"WATCH: Oregon State Spring Practice Interviews - Day 9","slug":"watch-oregon-state-spring-practice-interviews-day-9","kind":"free","site_id":112,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-18T14:42:17.627-05:00","summary":"Hear from Oregon State running backs coach Michael Pitre, quarterback Conor Blount, and offensive lineman...","deleted":false,"author_name":"Brenden Slaughter","author_title":"Senior Writer","permalink":"https://oregonstate.rivals.com/news/watch-oregon-state-spring-practice-interviews-day-9","site_name":"BeaversEdge.com","type":"Content","programming":[],"associated_links":[{"id":535,"url":"https://oregonstate.forums.rivals.com/forums/the-dam-board.8/","display_text":"The Dam Board","content_id":null,"created_at":"2017-02-15T15:24:56.986-06:00","updated_at":"2017-12-09T10:51:51.050-06:00","setting_id":132,"ordinality":1},{"id":536,"url":"https://oregonstate.rivals.com/news/beaversedge-com-testimonial-page","display_text":"Why subscribe to BeaversEdge?","content_id":null,"created_at":"2017-02-15T15:24:56.992-06:00","updated_at":"2017-09-27T09:43:48.538-05:00","setting_id":132,"ordinality":2}]},{"id":1915240,"title":"Oregon State Women&#x0027;s Basketball: 2017-18 Season Highlight Video","slug":"oregon-state-women-s-basketball-2017-18-season-highlight-video","kind":"free","site_id":112,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-04-18T10:55:54.753-05:00","summary":"The official Oregon State athletics YouTube page posted a 14 minute video to recap the Beavers&#x0027; epic 2017-18 season.","deleted":false,"author_name":"BeaversEdge.com","author_title":"Staff","permalink":"https://oregonstate.rivals.com/news/oregon-state-women-s-basketball-2017-18-season-highlight-video","site_name":"BeaversEdge.com","type":"Content","programming":[],"associated_links":[{"id":535,"url":"https://oregonstate.forums.rivals.com/forums/the-dam-board.8/","display_text":"The Dam Board","content_id":null,"created_at":"2017-02-15T15:24:56.986-06:00","updated_at":"2017-12-09T10:51:51.050-06:00","setting_id":132,"ordinality":1},{"id":536,"url":"https://oregonstate.rivals.com/news/beaversedge-com-testimonial-page","display_text":"Why subscribe to BeaversEdge?","content_id":null,"created_at":"2017-02-15T15:24:56.992-06:00","updated_at":"2017-09-27T09:43:48.538-05:00","setting_id":132,"ordinality":2}]}], nil, 112, nil, true); subdomain = &#x0027;oregonstate&#x0027;; aolPlayerId = &#x0027;58e686759efa8936610b8215&#x0027;; aolCompanyId = &#x0027;58e68374c7480e728bcc385f&#x0027;'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>
<div class='article-container new'>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header news-header' style='background: #000000'>
Ticker
</div>
<div class='news' ng-repeat='content in newsList()'>
<div class='article' ng-if='content.type === "Content"'>
<div class='forum-icon' ng-if='forumThread(content.content_type)'></div>
<a class='title' href='{{content.permalink}}' ng-class="{'indent': content.kind === 'premium'}">
<div ng-cloak>{{content.title}}</div>
</a>
<div class='byline'>
<div class='premium-icon' ng-if='content.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='link-icon' ng-if='link(content.content_type)'><?xml version="1.0" encoding="utf-8"?>
<!-- Generator: Adobe Illustrator 19.1.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->

<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" x="0px" y="0px" viewbox="0 0 16 12.2" enable-background="new 0 0 16 12.2" xml:space="preserve">
  <path id="XMLID_228_" fill="#0A4EA3" d="M9.1,8.8C8.3,10,7,10.7,5.5,10.7c-2.4,0-4.3-1.9-4.3-4.3s1.9-4.3,4.3-4.3
      c1.4,0,2.6,0.7,3.4,1.7h1.2C9.2,2.3,7.5,1.2,5.5,1.2c-2.9,0-5.3,2.4-5.3,5.3s2.4,5.3,5.3,5.3c2,0,3.8-1.2,4.7-2.9H9.1z"></path>
  <polygon id="XMLID_229_" fill="#0A4EA3" points="16.2,6.1 13.8,3.7 13.8,6.2 5.8,6.2 5.8,7.2 13.8,7.2 13.8,8.6 	"></polygon>
</svg>
</div>
<time datetime='{{content.live_at}}' ng-cloak>
{{timeAgo(content.live_at)}}
</time>
<a class='edit-article' href='/publishing/contents/{{content.id}}/edit' ng-show='$parent.isPublisher'>Edit</a>
</div>
</div>
<div class='tweet' ng-if='content.type === "Tweet"'>
<div class='tweet-icon'></div>
<a class='title' href='{{content.tweet_url}}' target='_blank'>
<div ng-bind-html='content.text_news_feed'></div>
</a>
</div>
</div>
</div>

<div class='side-rail-meta lrec-ad' ng-if="showLRECad('leftrail-below-ticker')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad2'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>

<rv-homepage-forums ad-referer='https://oregonstate.rivals.com/news/fowler-raves-about-oregon-state-visit' background-color='#000000' base-api-url='https://oregonstate.forums.rivals.com/' homepage='false' message-board-url='oregonstate.forums.rivals.com' pub-ad='null' size='size' space-id='2022733135' subscribed-user='subscribedUser'></rv-homepage-forums>


<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='new-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://oregonstate.rivals.com/news/fowler-raves-about-oregon-state-visit/printable' site-name='BeaversEdge.com'></rv-share-links>
</div>
<div class='premium-icon'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2018-04-25 11:34:35 -0500') }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(subdomain)}}//publishing/contents/1917523/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Fowler raves about Oregon State visit</h2>
<div class='header-image'><figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/ndulp6zglbavaipvavck)'></div>
<img src="https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/ndulp6zglbavaipvavck" alt="Ndulp6zglbavaipvavck" />
</div>
<figcaption class='image-caption'></figcaption>
<div class='image-credit'></div>
</figure>
</div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<img class='circle-img' src='https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_author_bio/b3io5mvoryqteet2n7vr'>
<span>
<span class='title-sm'>
Mike Singer
&bull;
</span>
<span class='type-sm'>BeaversEdge.com</span>
<div class='type-sm'>
<a href='//twitter.com/Beavers_Edge' target='_blank'>@Beavers_Edge</a>
</div>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='title-sm'>BeaversEdge.com</span>
</span>
<script async charset='utf-8' src='//platform.twitter.com/widgets.js'></script>
<a class='twitter-follow-button' data-show-count='false' data-show-screen-name='false' data-size='large' href='//twitter.com/Beavers_Edge'></a>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>

</div>
</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='upsell'>
<div class='preview-container'>
<div class='article-preview'></div>
<div class='fade-container'>
<div class='article-fade'></div>
<div class='st__content-block st__content-block--text article-text'>
<p>Bellevue (Wash.) inside linebacker Drew Fowler earned an offer from the Oregon State Beavers on April 10, and it didn&#39;t take the 6-foot-2, 210-pounder very long to get on campus and check out Corva...</p>

</div>

</div>
</div>
<div class='upsell-content'>
<div class='row premium-divider'>
<div class='col-sm-8 col-xs-6'>
<hr>
</div>
<div class='premium-content col-sm-8 col-xs-12'>
<div class='premium-icon'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<span>Premium Content</span>
</div>
<div class='col-sm-8 col-xs-6'>
<hr>
</div>
</div>
<h3 class='upsell-headline'>Subscribe today to read the full article and get everything Rivals has to offer.</h3>
<div class='row buttons'>
<div class='col-xs-24 col-sm-12'>
<div class='subscribe'>
<a class="btn" href="/sign_up?preselected_site_id=112">Subscribe to Rivals</a>
</div>
</div>
<div class='sign-in col-xs-24 col-sm-12'>
<a class="btn" href="/users/sign_in">Sign in</a>
</div>
</div>
<div class='value-props row'>
<ul>
<li class='value-prop fa-before fa-check'>Member-only message boards</li>
<li class='value-prop fa-before fa-check'>Exclusive highlights and recruiting interviews</li>
<li class='value-prop fa-before fa-check'>Exclusive coverage of Rivals Camp Series</li>
<li class='value-prop fa-before fa-check'>Breaking recruiting news</li>
</ul>
</div>
</div>
<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>

</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://oregonstate.rivals.com/news/fowler-raves-about-oregon-state-visit/printable' site-name='BeaversEdge.com'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>

</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[{"active":true,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Schedule","football":false,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Commitment","football":true,"list_id":null,"list_title":null,"position":3}]' is-super-admin='' ncaab-schedule-year='2017' ncaaf-schedule-year='2018' new-article-layout='true' site='{"id":112,"legacy_id":1051,"name":"BeaversEdge.com","friendly_name":"Oregon State","annual_discount":null,"subdomain":"oregonstate","primary_color":"000000","secondary_color":"ff8c1f","font_color":"ffffff","short_name":"oregonstate","maple_ncaaf_team_id":61,"maple_ncaaf_endpoint":"ncaaf/teams/oof","maple_ncaab_team_id":450,"maple_ncaab_endpoint":"ncaab/teams/oak","maple_college_id":61,"google_analytics_id":"UA-81917412-1"}' twitter-feed='{"id":112,"site_id":112,"handle":"Rivals_Singer","list_name":"BeaversEdge","created_at":"2016-02-01T12:25:18.756-06:00","updated_at":"2017-02-15T15:23:02.047-06:00","hashtags":[],"usernames":["Beavers_Edge"],"max_number":2}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://oregonstate.rivals.com/news/fowler-raves-about-oregon-state-visit/printable' site-name='BeaversEdge.com'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022733135', 'https://oregonstate.rivals.com/news/fowler-raves-about-oregon-state-visit');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Fowler raves about Oregon State visit";
  _sf_async_config.sections = 'content,content-football,content-football-premium,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
</div>
<div class='OUTBRAIN' data-ob-template='Rivals.com' data-src='https://oregonstate.rivals.com' data-widget-id='AR_4'></div>
<script src='https://widgets.outbrain.com/outbrain.js' type='text/javascript'></script>
</div>

</div>
</main>
<footer>
<ul class='footer-links list-inline'>
<li>
<a href='https://n.rivals.com/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='https://policies.yahoo.com/us/en/yahoo/ip/index.htm'>Copyright/IP Policy</a>
<a href='https://n.rivals.com/news/contact-us-5'>Contact Us</a>
<a href='/tos'>Terms of Service</a>
<a href='https://n.rivals.com/news/member-services'>Member Services</a>
</li>
</ul>
<div class='copyright-notice'>&copy; Yahoo! Inc.</div>
</footer>
</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022733135",
    c7: "https://oregonstate.rivals.com/news/fowler-raves-about-oregon-state-visit"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Foregonstate.rivals.com%2Fnews%2Ffowler-raves-about-oregon-state-visit&c5=2022733135&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
